Chapter 11: User Interface Reference

<< Previous Chapter | Table of Contents | Next Chapter >>

Application Frame

The POMS application frame is illustrated below. This window is displayed after successful user login.

The frame window consist of:

The dividing line between the navigation tree and the contents panel is adjustable. Drag it left or right to suit your preferences.

POMS Node

The POMS tree node contains five sub-nodes:

Publishing Documents

There are three ways you can add or change publications:

The user interface for the third method (which also allows you to view and navigate through publications) is illustrated below.

The left panel shows the local file hierarchy. The right panel shows the remote file hierarchy.

For Publications, the location of the remote file hierarchy is according to your Application Configuration. The default directory for this is <root>/prag/publish/. In a new installation, there are initially no publications, but you can add them at any time. This is handy for publishing documents relevant to your organization to all users.

For My Documents, the location of the remote file hierarchy is according to your Application Configuration. The default directory for this is <root>/prag/userdocs/user_<id>/, where <id> denotes the numeric ID of a specific user (e.g., 1). In a new installation, there are initially no such documents, but you can add them at any time. This is handy for publishing documents targeted to individual users (e.g., confidential information).

You can do the following on local/remote sides:

Project Dashboard

The Project Dashboard allows you to view summary information about projects for a given period.

The screen consists of the following parts:

The first time you enter this dashboard, and when you make changes to the filter or formulas, you should press the Calculate Summaries button to update the information at the buttom of the screen.

You can navigate from the Specific Summary tab to a project by either double-clicking its row, or selecting the row and pressing the Details button.

If you want the Specific Summary to cover only certain projects, then you should select the second radio button for Specific Scope, and press the Select Projects button. The following dialog is displayed.

Tick the desired projects and press the OK button.


Menubar

File Menu

The File menu provides a set of commands for creating objects, saving changes to them, and printing.

The File | New command displays the following dialog for creating new objects.

When you select an object type in this dialog, a message at the top of the dialog indicates whether you have permission to create it. Select the desired object type and press the OK button to create it. As soon as the object is created, it is added to the navigation tree, as a child of the relevant node, and its content is displayed.

The File | Save command is enabled when you select an object in the navigation tree that has been modified. The name of a tree node that has been modified in always prefixed with a * to indicate unsaved changes. Selecting this command causes the object to be saved (i.e., the modified object is written to the database).

The File | Save All command is enabled when there are one or more objects in the navigation tree that have been modified. Selecting this command causes all such objects to be saved.

The File | Print Preview command is enabled when the currently-selected node in the navigation tree has HTML contents. Selecting this command causes the HTML data to be opened in a separate web browser window for viewing and printing.

The File | Exit command terminates the POMS client session. If there are any unsaved objects, you will be asked whether you want to save them before exiting.

Edit Menu

The Edit menu provides a set of commands that affect the currently-selected tree node, and for searching.

The Edit | Hide command is enabled when the currently-selected node in the navigation tree represents a POMS object (e.g., a project). Selecting this command causes the node to be removed from the navigation tree. The object itself will not be affected, only its representation in the tree will be removed from view. If the object has unsaved changes, you will be asked whether you want to save them.

The Edit | Unlock command is enabled when the currently-selected node in the navigation tree represents a POMS object (e.g., a project) that has been locked (by yourself or someone else) and that you have permission to unlock it. Selecting this command causes the object to be unlocked. As a result, any unsaved changes to the object are discarded and the object is reloaded from the database.

Unlocking is useful in two situations:

The Edit | Delete command is enabled when the currently-selected node in the navigation tree represents a POMS object (e.g., a project) and you have permission to delete it. Selecting this command causes the object to be permanently deleted from the database. You will always be asked to confirm this operation.

The Edit | Search command displays the following dialog for searching.

Select the type of object you want to search for and press the OK button. The corresponding search screen in the navigation tree will be selected so that you can initiate your search.

View Menu

This View menu provides a set of commands that control the navigation tree-based view.

The View | Toggle Navigation Tree command hides the navigation tree, so that more real estate is available for displaying the content panel. Selecting this command again causes the navigation tree to re-appear.

The View | Previous Tree Node command causes the previously-selected navigation tree node to be selected. You can select this command multiple times to travel back through the navigation chain. Conversely, you can go forward in the chain by selecting the View | Next Tree Node command.

The View | Reload Tree Node command is enabled when the currently-selected node in the navigation tree represents a POMS object (e.g., a project). Selecting it causes the object to be reloaded from the database. If you have modified the object, you will be asked whether you want to save your changes before reloading the object. This command is similar to Edit | Unlock, except that it keeps a locked object as locked.

Tools Menu

The Tools menu provides the following commands.

The Tools | Change Password command displays the following dialog for changing your password.

Enter your old and new passwords and press the OK button to save your change.

The Tools | Generate Report command is enabled when you are currently viewing either a search screen or a POMS object. It displays a dialog for generating a report that captures the search result or the POMS object. Please refer to Chapter 8 for details.

The Tools | Show Underlying XML command is enabled when the currently-selected node in the navigation tree represents a POMS object (e.g., a project). Selecting this command causes an XML representation of the object to be displayed in a web browser window.

The Tools | Refresh Pick Lists command causes the contents of all pick lists to be reloaded from the database. This is useful when another user has made changes to a pick list since you logged-in (e.g., created a new user) and you want to get these changes. Any changes made by yourself to a pick list are automatically reflected in your session, so you don't need this command to see them.

The Tools | Edit Pick Lists command selects the Pick Lists node in the navigation tree, so that you can edit a pick list.

The Tools | Options command selects the User Options node in the navigation tree, so that you can set your personal preferences.

Help Menu

The Help menu provides the following commands.

The Help | General command selects the POMS node in the navigation tree and displays its underlying HTML, which provides some useful general information about the application.

The Help | Contents command opens the Contents page for the POMS User Guide in a web browser window.

The Help | PragSoft Web Site command opens the PragSoft home page in a browser window, where you can view and download the latest release of POMS.

The Help | Buy License Online command opens the PragSoft online store page in a browser window, where you can purchase POMS licenses using a credit card.

The Help | License command displays the following dialog for viewing/specifying the application license details.

When you receive a software license from PragSoft, login as admin user, go to this dialog and enter the license details into the fields exactly as provided, and press OK to permanently save your license. For non-admin users, the license dialog appears as read-only. For security, the Key Code field is always displayed as empty.

To view the License Agreement, press the Agreement button. The license agreement is displayed in a web browser window.

The Help | About POMS command displays the following dialog, which provides some useful information about the application.


Toolbar

The toolbar at the top of the application window (below the menubar) provides iconic representations for frequently-used commands. These buttons are enabled/disabled depending on where you are in the applications and your security permission rights.

This is a shortcut for File | New.
This is a shortcut for File | Save.
This is a shortcut for File | Save All.
This is a shortcut for File | Print Preview.
This is a shortcut for Edit | Hide.
This is a shortcut for Edit | Unlock.
This is a shortcut for Edit | Delete.
This is a shortcut for Edit | Search.
This is a shortcut for View | Toggle Navigation Tree.
This is a shortcut for View | Previous Tree Node.
This is a shortcut for View | Next Tree Node.
This is a shortcut for View | Reload Tree Node.
This is a shortcut for Tools | Generate Report.
This is a shortcut for Tools | Show Underlying XML.
This is a shortcut for Help | General.


Generic Features

The POMS user interface has a number of generic features used throughout the application. These are described below.

Search Fields

In search screens, fields that have a light blue background support fast searches when the data set is very large. When you specify search criteria, where possible, you should use these fields for more efficient searching. For small data sets (e.g., hundreds of items) the searches will be fast regardless, even if you specify no search criteria.

A search field that has a red percentage icon next to it, supports wildcards (specified by % symbols). For example, entering "%mix%" will match any string that has "mix" in it. A search field that has a red key icon next to it, supports keyword matching. For example, entering "server deploy" will match any string that contains "server" and "deploy" in any order.

Date Fields

Fields that display date (or date and time) look like this:

You can configure your preferred date format in User Options. For example, if you choose your preferred format as dd MMM yyyy (e.g., 12 Jun 2005), then all date fields display date in this format and expect you to enter a date in the same format.

When you edit the contents of a date field, the tick button to the right of the field becomes enabled. Pressing the button causes the change to take effect (provided it is a valid date). Tabbing out of a date field (i.e., pressing the tab key) has the same effect. If the new date is invalid, the field will be cleared. You can also clear a date filed by deleting its contents. Alternatively, right-click on the field and select Clear from its popup menu.

Some users prefer to specify a date visually, using a calendar. To do this, double-click the date field, or right-click on it and select Calendar from its popup menu. A calendar dialog is displayed.

Select your date by clicking on it and then press the OK button. The selected date will appear in your date field.

Current Date/Time

In three and four-tire installations, the client and server components may have been geographically distributed across regions that have different timezones (e.g., across states, countries, or continents). To ensure a consistent view of current date/time, POMS always uses the current date as provided by the App Server(s). For example, if a client creates a project, the project creation time is set to the current time in the App Server timezone (which may be different from the client timezone).

Numeric Fields

Fields that display currency, percentage, or just a number, look like this:

These behave similarly to date fields, except that they expect numeric data. Currency fields are formatted according to the way currency has been configured in your installation profile.

To set a numeric field visually, double-click it or right click on it and select Calculator from the popup menu. A calculator dialog is displayed.

Enter or calculate a value and then press the OK button. The final number will appear in your numeric field.

Tables

Tables are used extensively in the POMS user interface. Tables provide a number of useful features that may not be initially obvious:


<< Previous Chapter | Table of Contents | Next Chapter >>

Copyright 2005 PragSoft Corporation (www.pragsoft.com)